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1. Introduction to Kernel for BKF 

Welcome to the user manual for Kernel for BKF, the most effective and convenient file repair tool that 
repairs and fixes corrupted MS backup files damaged due to virus corruption, backup interruption or 
unexpected system shutdown. This user manual comprises step by step guidelines on using Kernel for 
BKF. 

1.1  Using this Manual 

This user manual is intended to guide users on using Kernel for BKF. We suggest that first time users 
should read this user manual completely and carefully before proceeding to use the software. However, if 
you are an experienced user, you can use the table of contents to find out information pertaining to the 
tasks that you need to perform by using Kernel for BKF. 

You can use the table of contents to navigate through different sections of this user manual. The table of 
contents lists all the sections that are contained in this user manual in chronological order. The user 
manual comprises the following sections: 

 Introduction 

 Getting Started 

 Software Interface 

 Repairing .corrupt BKF files 

 Customizing Repaired Files 

 Saving Repaired Files 

 Full Version 

 Support 

 Troubleshooting 

 Legal Notices 

Certain abbreviations have been used throughout this manual. For clear understanding of the contents of 
this user manual, please go through the list of abbreviations, mentioned below, before reading the manual.  

1.1.1 List of Abbreviations 

MS: Microsoft 

BKF: Backup Files 

RAM: Random Access Memory 
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MB: Mega-Byte 

GB: Giga-Byte 

1.2 About Kernel for BKF 

Kernel for BKF - Corrupt Backup Repair Software repairs and fixes corrupted MS Backup files damaged 
due to following reasons and error messages such as - 

 CRC (cyclic redundancy check) errors 

 "Fails to open file " 

 Virus Corruption 

 Unexpected system shutdown 

 Backup interruption 

Kernel for BKF - Corrupted Backup Repair Software recovers files from corrupted BKF archives damaged 
due to backup interruptions, virus attacks or CRC errors. 

During the repairing process, a complete scan of the damaged BKF file is performed to locate and extract 
the recoverable files. After complete scanning, the files which are recoverable are recovered and copied at 
the user defined location. 

1.3 Salient Features 

Salient features of Kernel for BKF include: 

 Repairs corrupt BKF archive 

 Supports Unicode characters (Non English Characters) 

 Save Snapshot option which allows you to save the details of a bkf file scan so that later you can use 
Load Snapshot option to resume the saved scan process, which helps you save the rescanning time. 

 Option to quickly search and locate a file. 

 Repairs CRC errors. 

 Supports bkf files created with Backup Exec by VERITAS Software, under Windows, Novell, and 
Macintosh. 

 New Enhanced User friendly interface, no technical skills required. 
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1.4 Who Should Use this Software? 

The capability of Kernel for BKF to repair corrupt BKF files makes it appropriate for use by people, who 
are striving to recover data from corrupt or inaccessible BKF files. Kernel for BKF repairs and fixes corrupt 
MS backup files that are damaged due to virus attack, improper system shutdown, CRC (cyclic 
redundancy check) errors, backup interruptions and other operational errors. 
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2. Getting Started 

Now that you have understood the features and potential of Kernel for BKF, you are ready to get hands on 
experience of the software. To start repairing bkf files, you will first need to download and install this 
software. 

It is strongly recommended that before installing Kernel for BKF, you should go through the installation 
pre-requisites for the software, so that it can be assured that your computer is appropriately configured to 
run the software. 

2.1 Installation Pre-requisites 

Kernel for BKF works on all Windows-based computers. Following are detailed minimum system 
requirements for the Host Computer: 

2.1.1 Hardware Requirements: 

The hardware requirements for installing the software are as follows: 

 Pentium II 400 MHz  

 Minimum 64MB RAM (128 MB recommended) 

 Enough space to save the recovered data; for example, if you expect to recover 40 MB lost data, 
the good device should have at least 40 MB free space. 

2.1.2 Operating System Requirements: 

Supported Operating Systems: 

 Windows Vista 

 Windows XP 

 Windows 2003 

 Windows 2000 

2.1.3 Supported BKF files 

Supports all versions of BKF files created using MS backup or VERITAS backup software. 

 

2.2 Downloading Kernel for BKF for the First Time 

After checking your computer with the prescribed system requirements for Kernel for BKF, you can 
download and install the software on your computer. You can buy the full version of the software from any 
one of our authorized resellers– Element5, Asknet and 2CO. 
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If you want to try Kernel for BKF before buying it, you can download the evaluation version from the 
following link: 

http://www.nucleustechnologies.com/Download-BKF-File-Repair-Software.php 

2.3 Install Kernel for BKF 

After downloading the installer file for Kernel for BKF, you can install the software by running the file. To 
install Kernel for BKF: 

1. Double-click the Kernel for BKF installer. Follow the on-screen instructions. 

The Setup Installation Complete screen will be displayed. 

2. Click Finish to launch the software. 

2.4 Start Kernel for BKF 

To start Kernel for BKF: 

Click the Start  All Programs Kernel for BKF 

Alternatively, you can launch Kernel for BKF by double-clicking the shortcut icon available on the Desktop 
and Quick Launch icon. 

2.5 Uninstall Kernel for BKF 

You may need to uninstall and re-install Kernel for BKF. To uninstall Kernel for BKF: 

1. Click the Start  All Programs Kernel for BKF  Uninstall Kernel for BKF 

A warning message will be displayed. 

2. Click Yes to uninstall Kernel for BKF. 

 Before proceeding to uninstall Kernel for BKF, you must ensure that the software is 
not running on your computer. 

You can alternatively uninstall Kernel for BKF from the Control Panel by performing the following steps: 

1. Click the Start Menu  Control Panel and then double click the Add or Remove Programs icon. 

2.  Select Kernel for BKF and click Remove. 

A warning message will be displayed. 

3. Click Yes to uninstall Kernel for BKF.  

http://www.nucleustechnologies.com/Download-BKF-File-Repair-Software.php
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3. Software Interface 

Now that Kernel for BKF has been installed on your computer, you can start using the software after 
getting acquainted with the software interface. 

3.1 Menu-bar 

The menu-bar of Kernel for BKF comprises three main menus– File, View, and Help. 

3.1.1 File Menu 

The File menu comprises four menu items. 

  

Figure 3.1: File Menu 

Menu items in the File menu 

Field Name Field Description 

Recover Starts the recovery process 

Save Recovery 
Snapshot 

Saves the scanned BKF file 

Load Recovery 
Snapshot 

Loads the saved recovery snapshot whenever you start the 
recovery process again 

Exit Close Kernel for BKF 

3.1.2 Tools Menu 

The Tools menu comprises three menu items. 

 

Figure 3.2: Tools Menu 
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Menu Items in the Tools menu: 

Field Name Field Description 

Live Update Updates the software with new version available 
on the Nucleus server 

Settings Specify the name of the folder (name prefix) 
which will contain the recovered files. 

Search Files Search specific files from the large number of 
recovered files 

3.1.3 Help Menu 

The Help menu comprises two menu items. 

  

Figure 3.3: Help Menu 

Menu items in the Help menu: 

Field Name Field Description 

Software Help Select to view help information pertaining to performing 
various tasks using Kernel for BKF. 

Visit Software Homepage Select to visit software homepage on our website 

About Kernel for BKF Select to view version-related and support information of 
Kernel for BKF 

3.2 Tool-bar 

The tool-bar in Kernel for BKF is displayed below the menu-bar. The tool-bar provides a convenient and 
user-friendly method to perform certain actions that can also be performed by using the menu-bar. Read 
the information in the table below to find out about the tool-bar buttons: 
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Button Button Name Button Description 

 

Recover Click this button to start the recovery process 

 

Save Snapshot Click this button to save the scanned BKF file 

 

Load Snapshot Click this button to load the saved recovery 
snapshot  

 

Search Files Click this button to search specific files from the 
large number of recovered files 

 

Live Update Click this button to update the software with new 
version available on the Nucleus server 

 

Help Click this button to view help of the software 

 

About Click this button to view the version and other 
information related to the software. 

 

Buy Online Click this button to purchase the software online 
from the website. 
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3.3 Status Bar 

 Status bar is displayed at the bottom of the software window. The text „Ready‟ is displayed on the status 
bar if Kernel for BKF is ready to be used. Status bar also displays the text „CAP‟, „NUM‟, „SCRL‟ which 
respectively correspond to the Caps Lock, Num Lock, and Scroll Lock keys on your keyboard. If any of 
these keys are pressed, the color of the corresponding text will turn blue/black. 

 

Figure 3.4: Status Bar 

3.4 Customize User Interface 

You can add or remove toolbar buttons by clicking: 

  Standard in the toolbar and selecting appropriate buttons. 
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4. Repairing Corrupt BKF Files 

To recover the corrupt BKF files, perform the following steps: 

 In Windows, Click Start > All Programs > Nucleus Kernel BKF Recovery > Nucleus Kernel 
BKF Recovery. The main window of software will be displayed. 

 

Figure 4.1: Main Window 

 Click 'Browse' button in the main window to select the corrupted .bkf file from the list. A dialogue 
box: Select BKF File for Recovery will appear. 

 Select corrupted .bkf file and click 'Open' to add the selected file. 
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Figure 4.2: Dialog Box 

 With Kernel for BKF only single file can be selected and repaired at a time. 

 Click 'Recover' to start the process of recovery. The process of repairing the selected .bkf file will 
start. 

 

Figure 4.3: Corrupted BKF File 
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 Once recovery process is complete, all the recovered files will be listed on the screen of Kernel for 
BKF. You can save all the recovered files or select any specific file which you want to save by 
deselecting the check box of other files. 

 

Figure 4.4: Recovered Files 
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5. Customizing Repaired Files 

Kernel for BKF - Corrupted Backup Repair Software provides you with the option to personalize the folder 
which has the saved repaired files. It provides you to customize the name of the Rec folder. To configure 
the name of the Rec folder perform the following steps: 

 Click Tools Menu> Setting.from the toolbar, the 'Folder Setting' screen will be displayed. 

 

Figure 5.1: Folder Setting 

 In the Folder Setting screen, type the desired name that you want to give to the folder which 
saves the repaired file and click OK. The name of the Rec folder is successfully modified. 

 Kernel for BKF by default sets the name of the folder as "Rec” 
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6. Saving Repaired Files 

To save the repaired BKF files, perform the following steps:  

 After repairing of corrupted BKF files, Kernel for BKF - Backup Repair Software displays the 
repaired files in a tree like structure: 

 You can select individual file for saving by deselecting other file(s) checkboxes. Select the file and 
press Ctrl key from the keyboard and simultaneously right click the mouse. 

 If all the repaired files have to be saved then click the 'Save' button without deselecting any file. A 
new dialogue box to define the location where the selected files will be saved will appear. 

 Select the desired location and click OK. The process of saving file(s) will start. 

 After the successful saving, a message “Saving Complete” will appear. Click OK. 
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7. Full Version 

Although you can use Kernel for BKF evaluation version for free and experience the capabilities of the 
software, but there are certain features that are not available in the evaluation version. 

7.1 Requirement of Full Version 

By using the evaluation version of Kernel for BKF, you can repair corrupt BKF files; however, you cannot 
save the repaired files. You will need to buy the full version of the software to save the repaired files. 

7.2 Purchasing Full Version 

You can buy the full version of Kernel for BKF from any of our authorized resellers – Element5, Asknet 
and 2CO. 

As soon as the purchase transaction with our resellers gets completed, our sales team will send you an 
email comprising the URL to download the full version of Kernel for BKF and activation details of the 
software. 
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8. Support 

We have an extensive and efficient support system in place to assist our customers with all issues related 
to using Kernel for BKF. The software comes with an embedded help manual that can be accessed by 
clicking HelpSoftware Help in the menu-bar. You can also press the F1 key on the keyboard of your 
computer to access the embedded help of Kernel for BKF. 

You can access the online help for Kernel for BKF at http://www.nucleustechnologies.com/Online-
Helps.html 

We also have live support wherein you can chat with our software experts at 

http://www.nucleustechnologies.com/Support.html 

To talk on phone with our software experts call: 

Help line:  
 

+91-9818725861 

1-866-348-7872 (Toll Free for USA/CANADA) 

You can also email us about your queries at; 

sales@nucleustechnologies.com for Sales 

support@nucleustechnologies.com for Support 

contact@nucleustechnologies.com for General Queries 

  

http://www.nucleustechnologies.com/Online-Helps.html
http://www.nucleustechnologies.com/Online-Helps.html
http://www.nucleustechnologies.com/Support.html
mailto:sales@nucleustechnologies.com
mailto:support@nucleustechnologies.com
mailto:contact@nucleustechnologies.com
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9. Troubleshooting 

This section deals with your generic and specific queries pertaining to using Kernel for BKF. 

9.1 Common Issues 

Why does Kernel for BKF have limitations in evaluation copy? 

The free evaluation version of Kernel for BKF is intended to enable you to experience the capabilities of 
the software. You will need to buy the software to view and save restricted text and images. 

9.2 Frequently Asked Questions 

How to Buy Kernel for BKF? 

You can buy Kernel for BKF online at http://www.nucleustechnologies.com/Buy-BKF-File-Repair-
Software.php 

I have lost my full version for Kernel for BKF. Can you help me? 

Please email us at sales@nucleustechnologies.com. Please include your name, address, email address, 
and order confirmation number (if you have it). We will be happy to help you. 

  

http://www.nucleustechnologies.com/Buy-BKF-File-Repair-Software.php
http://www.nucleustechnologies.com/Buy-BKF-File-Repair-Software.php
mailto:sales@nucleustechnologies.com
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10. Legal Notices 

This section comprises the legal specification about Kernel for BKF and the company NUCLEUS DATA 
RECOVERY.COM PRIVATE LIMITED  

10.1 Copyright 

NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED, Nucleus Kernel accompanied user manual and 
documentation are copyright of NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED, with all rights 
reserved. Under the copyright laws, this user manual cannot be reproduced in any form without the prior 
written permission of NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. No Patent Liability is 
assumed, however, with respect to the use of the information contained herein. 

© NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. All rights reserved. 

10.2 Trademark 

Nucleus Kernel ® is a copyright work of NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED 

Windows 95®, Windows 98®, Windows ME®, Windows NT®, Windows 2000 Server®, Windows 2000 
Advanced Server®, Windows 2003 Server®, Windows XP®, Windows Vista, MS-DOS and MS Office are 
registered trademarks of Microsoft Corporation. 

All other brand and product names are trademarks or registered trademarks of their respective companies. 

10.3 Disclaimer 

The Information contained in this manual, including but not limited to any product specifications, is subject 
to change without notice. NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED provides no warranty 
with regard to this manual or any other information contained herein and here by expressly disclaims any 
implied warranties of merchantability or fitness for any particular purpose with regard to any of the 
foregoing NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED assumes no liability for any damages 
incurred directly or indirectly from any technical or typographical errors or omissions contained herein or 
for discrepancies between the product and the manual. In no event shall NUCLEUS DATA 
RECOVERY.COM PRIVATE LIMITED, be liable for any incidental, consequential special, or exemplary 
damages, whether based on tort, contract or otherwise, arising out of or in connection with this manual or 
any other information contained herein or the use there of. 

10.4 License Agreement 

Kernel for BKF Copyright © by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED 

Your Agreement to this License 

You should carefully read the following terms and conditions before using, installing or distributing this 
software, unless you have a different license agreement signed by NUCLEUS DATA RECOVERY.COM 
PRIVATE LIMITED. The terms and conditions of this License describe the permitted use and users of 
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each Licensed Copy of Kernel for BKF. For purposes of this License, if you have a valid license, you have 
the right to use a single Licensed Copy of Nucleus Kernel. 

Scope of License 

Each Licensed Copy of Kernel for BKF may either be used by a single person or used non-simultaneously 
by multiple people who use the software personally installed on a single workstation. All rights of any kind 
in Nucleus Kernel, which are not expressly granted in this License, are entirely and exclusively reserved to 
and by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED. You may not rent, lease, modify, 
translate, reverse engineer, decompile, disassemble, or create derivative works based on, Nucleus Kernel, 
nor permit anyone else to do so. You may not make access to Nucleus Kernel available to others in 
connection with a service bureau, application service provider, or similar business, nor permit anyone else 
to do so. 

Warranty Disclaimers and Liability Limitations 

Kernel for BKF, and any and all accompanying software, files, data and materials, are distributed and 
provided AS IS and with no warranties of any kind, whether expressed or implied. In particular, there is no 
warranty for the quality of data recovered. You acknowledge that good data processing procedure dictates 
that any program, including Nucleus Kernel, must be thoroughly tested with non-critical data before there 
is any reliance on it, and you hereby assume the entire risk of all use of the copies of Nucleus Kernel 
covered by this License. This disclaimer of warranty constitutes an essential part of this License. In 
addition, in no event does NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED authorize you or 
anyone else to use Kernel for BKF in applications or systems where Kernel for BKF failure to perform can 
reasonably be expected to result in a significant physical injury, or in loss of life. Any such use is entirely at 
your own risk, and you agree to hold NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED harmless 
from any and all claims or losses relating to such unauthorized use. 

General 

This License is the complete statement of the agreement between the parties on the subject matter, and 
merges and supersedes all other or prior understandings, purchase orders, agreements and 
arrangements. This License shall be governed by the laws of the State of Delhi. Exclusive jurisdiction and 
venue for all matters relating to this License shall be in courts and for a located in the State of Delhi, and 
you consent to such jurisdiction and venue. There are no third party beneficiaries of any promises, 
obligations or representations made by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED herein. 

Any waiver by NUCLEUS DATA RECOVERY.COM PRIVATE LIMITED of any violation of this License by 
you shall not constitute, nor contribute to, a waiver by NUCLEUS DATA RECOVERY.COM PRIVATE 
LIMITED of any other or future violation of the same provision, or any other provision, of this License. 


